Time warp

Report any bugs you find here. Include the steps for reproducing it if you can, and the version number.
Wed Dec 14, 2016 9:39 pm

  • When playing a 6 player game with my freind and 4 bots after a while you notice that you cannot attack the odd creature or two, if you quit to desktop and go back into the game you notice they are not there....this happens alot they are not necessarily dead just not in the place you thought.
    This really annoying can someone please fix this bug...if anyone is still working on the game that is.
    Chat rubbish get blobbed !
    Lord kickstarter backer
    User avatar
    Lazarus
     
    Posts: 65
    Joined: Sun May 18, 2014 12:23 am
    Location: Nottingham UK

Thu Dec 15, 2016 9:47 am

  • Hi, CGR is still working on CR, but this isn't really his area; Julian's said that the rest of the team are focused on getting the new game off the ground, but should be back on CR in the new year.

    You may be able to clear these "ghost" creatures by clicking into and out of playback mode.

    If you can provide more information (a video would be perfect) about how this problem is happening, that would make it easier to fix.
    Image
    User avatar
    RafiRomero
     
    Posts: 1242
    Joined: Sat Apr 05, 2014 11:36 am
    Location: Cumbria, UK

Sun Dec 18, 2016 12:16 am

  • This is something that can occur in games versus AI wizards (in realms and custom games). I don't think I've ever seen it happen in a pure pvp game yet.

    I mostly notice it happening in 2v1 or 2v2 realm battles. I have also witnessed it occurring in custom games which involve several AI controlled wizards (1v3). The common denominator here is any format involving human players versus AI wizards.

    It is something that happens during the AI's turn when it is moving its creatures to various points.. when the glitch occurs the player (and ally) do not see the correct locations that the AI has moved them to. The creatures can appear to be several hex's away from their actual board position.

    The player only becomes aware of this glitch when they try to attack an enemy unit but cannot.. this is because the target is not situated on the exact hex shown. Another obvious indicator that this glitch has occurred is when two creatures are standing on top of each other, obviously their actual locations on the board are not being correctly displayed.

    I would say it happens at least once per realm run for me.. to solve the issue I fully 'log out' of the game, upon returning to the game you can see the correct locations of all the units present on the board. Myself and Gary play co-op formats versus AI's a lot, so for us it has become common practice to log out of realm battles (mid fight) once or twice an hour to remedy the problem.

    The other indicator that this glitch is occurring is when you haven't noticed it was happening and the AI's creatures suddenly warp to a hex that appeared to be out of their movement range. You will literally see a lion walk more than 3 hexes or a giant walk more than 2 hexes and attack something seemingly out of it's range.

    On one occasion the AI appeared to completely skip their turn, they had in fact taken their turn it just didn't register on my screen.. so I wonder if it is some kind of 'desync' issue (if that's the right term). It does somehow seem to be related to having a bad connection (with whatever server the AI's moves are stored on), logging out seems to act like clicking 'refresh' and getting an updated true image of the board.
    Mazy
     
    Posts: 1749
    Joined: Mon Oct 06, 2014 8:24 pm
    Location: UK

Sat Aug 12, 2017 2:25 am

  • ^^bump^^
    Mazy
     
    Posts: 1749
    Joined: Mon Oct 06, 2014 8:24 pm
    Location: UK

Sat Aug 12, 2017 7:03 am



Return to Bug Reports




Information
  • Who is online
  • Users browsing this forum: No registered users and 4 guests
cron