AI wizard using clone talisman didn't required adjacency

Report any bugs you find here. Include the steps for reproducing it if you can, and the version number.

  • An AI wizard armed with Volaticus Duplus - the ability to clone an adjacent creature, attempted to clone a creature that wasn't adjacent to it, an elephant. The elephant was situated 3 hexes away (the AI wizard was adjacent to an enemy rat and zombie at the time).

    The elephant did move beside the AI wizard later in the turn, but this was after the AI wizard already tried to clone it. There was only one puff of smoke (spell fail) so I don't think the AI wizard tried to cast an actual spell card after, the log message did say something about failing to cast or clone an elephant right after activating the cloning tali (details are a little sketchy, I should have taken screenshots of battle-log).

    I guess a few different things could be happening here... It looked like the AI wizard was able to do the cloning process in the wrong order.. it looked like it didn't require immediate adjacency and attempted to clone the creature before it moved adjacent to the wizard... or maybe it activated the tali but didn't use it and then tried to cast a regular elephant instead.

    One other theory is it might have had something to do with the +1 summoning range tali that the AI wizard also had.
    User avatar
    Mazy
     
    Posts: 1747
    Joined: Mon Oct 06, 2014 8:24 pm
    Location: UK


  • Thanks for reporting this, it has been fixed, and the fix will appear in the next update.
    User avatar
    CGR
    SNAPSHOT DEV
     
    Posts: 238
    Joined: Tue Mar 10, 2015 11:26 am
    Location: Seascale, Cumbria, UK




Return to Bug Reports




Information
  • Who is online
  • Users browsing this forum: No registered users and 5 guests
cron